summaryrefslogtreecommitdiff
path: root/python-pygments
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-03-11 12:24:25 +0100
committerKarel Kočí <cynerd@email.cz>2022-03-11 12:24:25 +0100
commitd1bed62641e895f0a1191c4c7844500b54b57828 (patch)
tree4524fbffd0a9db7b22ff9c71f61f36a8584dd303 /python-pygments
parent403d4e98cadc69a238060cce2614537f94a76ba9 (diff)
downloadopenwrt-personal-pkgs-d1bed62641e895f0a1191c4c7844500b54b57828.tar.gz
openwrt-personal-pkgs-d1bed62641e895f0a1191c4c7844500b54b57828.tar.bz2
openwrt-personal-pkgs-d1bed62641e895f0a1191c4c7844500b54b57828.zip
python-rich: add missing dependencies and update to latest version
Diffstat (limited to 'python-pygments')
-rw-r--r--python-pygments/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/python-pygments/Makefile b/python-pygments/Makefile
new file mode 100644
index 0000000..9db49ff
--- /dev/null
+++ b/python-pygments/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2022 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pygments
+PKG_VERSION:=2.11.2
+PKG_RELEASE:=1
+
+PKG_LICENSE:=BSD
+PKG_LICENSE_FILES:=LICENSE
+
+PYPI_NAME:=Pygments
+PKG_HASH:=4e426f72023d88d03b2fa258de560726ce890ff3b630f88c21cbb8b2503b8c6a
+
+include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-pygments
+ SECTION:=lang-python
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Pygments
+ URL:=https://pygments.org/
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-pygments/description
+ Pygments is a syntax highlighting package written in Python.
+endef
+
+$(eval $(call Py3Package,python3-pygments))
+$(eval $(call BuildPackage,python3-pygments))
+$(eval $(call BuildPackage,python3-pygments-src))