summaryrefslogtreecommitdiff
path: root/python-pygments/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'python-pygments/Makefile')
-rw-r--r--python-pygments/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/python-pygments/Makefile b/python-pygments/Makefile
new file mode 100644
index 0000000..9db49ff
--- /dev/null
+++ b/python-pygments/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2022 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pygments
+PKG_VERSION:=2.11.2
+PKG_RELEASE:=1
+
+PKG_LICENSE:=BSD
+PKG_LICENSE_FILES:=LICENSE
+
+PYPI_NAME:=Pygments
+PKG_HASH:=4e426f72023d88d03b2fa258de560726ce890ff3b630f88c21cbb8b2503b8c6a
+
+include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-pygments
+ SECTION:=lang-python
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Pygments
+ URL:=https://pygments.org/
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-pygments/description
+ Pygments is a syntax highlighting package written in Python.
+endef
+
+$(eval $(call Py3Package,python3-pygments))
+$(eval $(call BuildPackage,python3-pygments))
+$(eval $(call BuildPackage,python3-pygments-src))