summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-03-11 12:24:25 +0100
committerKarel Kočí <cynerd@email.cz>2022-03-11 12:24:25 +0100
commitd1bed62641e895f0a1191c4c7844500b54b57828 (patch)
tree4524fbffd0a9db7b22ff9c71f61f36a8584dd303
parent403d4e98cadc69a238060cce2614537f94a76ba9 (diff)
downloadopenwrt-personal-pkgs-d1bed62641e895f0a1191c4c7844500b54b57828.tar.gz
openwrt-personal-pkgs-d1bed62641e895f0a1191c4c7844500b54b57828.tar.bz2
openwrt-personal-pkgs-d1bed62641e895f0a1191c4c7844500b54b57828.zip
python-rich: add missing dependencies and update to latest version
-rw-r--r--python-commonmark/Makefile41
-rw-r--r--python-pygments/Makefile40
-rw-r--r--python-rich/Makefile8
3 files changed, 86 insertions, 3 deletions
diff --git a/python-commonmark/Makefile b/python-commonmark/Makefile
new file mode 100644
index 0000000..621dde4
--- /dev/null
+++ b/python-commonmark/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2022 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-commonmark
+PKG_VERSION:=0.9.1
+PKG_RELEASE:=1
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+PYPI_NAME:=commonmark
+PKG_HASH:=452f9dc859be7f06631ddcb328b6919c67984aca654e5fefb3914d54691aed60
+
+include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-commonmark
+ SECTION:=lang-python
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=CommonMark
+ URL:=https://github.com/rtfd/commonmark.py
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-commonmark/description
+ Markdown parser and renderer for the CommonMark specification, using only
+ native modules.
+endef
+
+$(eval $(call Py3Package,python3-commonmark))
+$(eval $(call BuildPackage,python3-commonmark))
+$(eval $(call BuildPackage,python3-commonmark-src))
diff --git a/python-pygments/Makefile b/python-pygments/Makefile
new file mode 100644
index 0000000..9db49ff
--- /dev/null
+++ b/python-pygments/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2022 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pygments
+PKG_VERSION:=2.11.2
+PKG_RELEASE:=1
+
+PKG_LICENSE:=BSD
+PKG_LICENSE_FILES:=LICENSE
+
+PYPI_NAME:=Pygments
+PKG_HASH:=4e426f72023d88d03b2fa258de560726ce890ff3b630f88c21cbb8b2503b8c6a
+
+include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-pygments
+ SECTION:=lang-python
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Pygments
+ URL:=https://pygments.org/
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-pygments/description
+ Pygments is a syntax highlighting package written in Python.
+endef
+
+$(eval $(call Py3Package,python3-pygments))
+$(eval $(call BuildPackage,python3-pygments))
+$(eval $(call BuildPackage,python3-pygments-src))
diff --git a/python-rich/Makefile b/python-rich/Makefile
index 924eae2..59c6679 100644
--- a/python-rich/Makefile
+++ b/python-rich/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-rich
-PKG_VERSION:=10.15.2
+PKG_VERSION:=12.0.0
PKG_RELEASE:=1
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
PYPI_NAME:=rich
-PKG_HASH:=1dded089b79dd042b3ab5cd63439a338e16652001f0c16e73acdcf4997ad772d
+PKG_HASH:=14bfd0507edc633e021b02c45cbf7ca22e33b513817627b8de3412f047a3e798
include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
include $(INCLUDE_DIR)/package.mk
@@ -27,7 +27,9 @@ define Package/python3-rich
SUBMENU:=Python
TITLE:=Render rich text and more to the terminal
URL:=https://github.com/willmcgugan/rich
- DEPENDS:=+python3-light
+ DEPENDS:=+python3-light \
+ +python3-pygments \
+ +python3-commonmark
VARIANT:=python3
endef