summaryrefslogtreecommitdiff
path: root/python-commonmark/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'python-commonmark/Makefile')
-rw-r--r--python-commonmark/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/python-commonmark/Makefile b/python-commonmark/Makefile
new file mode 100644
index 0000000..621dde4
--- /dev/null
+++ b/python-commonmark/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2022 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-commonmark
+PKG_VERSION:=0.9.1
+PKG_RELEASE:=1
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+PYPI_NAME:=commonmark
+PKG_HASH:=452f9dc859be7f06631ddcb328b6919c67984aca654e5fefb3914d54691aed60
+
+include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-commonmark
+ SECTION:=lang-python
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=CommonMark
+ URL:=https://github.com/rtfd/commonmark.py
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-commonmark/description
+ Markdown parser and renderer for the CommonMark specification, using only
+ native modules.
+endef
+
+$(eval $(call Py3Package,python3-commonmark))
+$(eval $(call BuildPackage,python3-commonmark))
+$(eval $(call BuildPackage,python3-commonmark-src))