summaryrefslogtreecommitdiff
path: root/dev-lua/luaposix/luaposix-33.4.0-r1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-09-13 23:42:32 +0200
committerKarel Kočí <cynerd@email.cz>2018-09-13 23:42:32 +0200
commitb19af87c5b49942893d86b0eeda5d30fb8d9b053 (patch)
tree0e26231fc3ac8749439250c182a8ce85a720f255 /dev-lua/luaposix/luaposix-33.4.0-r1.ebuild
parentebbb7e364a543e6aaf51d03b04a632bfd2ff289c (diff)
downloadgentoo-personal-overlay-b19af87c5b49942893d86b0eeda5d30fb8d9b053.tar.gz
gentoo-personal-overlay-b19af87c5b49942893d86b0eeda5d30fb8d9b053.tar.bz2
gentoo-personal-overlay-b19af87c5b49942893d86b0eeda5d30fb8d9b053.zip
luaposix: try to compile for multilib
Diffstat (limited to 'dev-lua/luaposix/luaposix-33.4.0-r1.ebuild')
-rw-r--r--dev-lua/luaposix/luaposix-33.4.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-lua/luaposix/luaposix-33.4.0-r1.ebuild b/dev-lua/luaposix/luaposix-33.4.0-r1.ebuild
new file mode 100644
index 0000000..bba50f2
--- /dev/null
+++ b/dev-lua/luaposix/luaposix-33.4.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit multilib-minimal
+
+DESCRIPTION="Bindings for POSIX APIs"
+HOMEPAGE="https://luaposix.github.io/luaposix/ https://github.com/luaposix/luaposix"
+SRC_URI="https://github.com/luaposix/luaposix/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-lang/lua:=[${MULTILIB_USEDEP}]
+ dev-lua/lua-compat[bit32]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S="${WORKDIR}"/${PN}-release-v${PV}
+
+src_prepare() {
+ multilib_copy_sources
+}