summaryrefslogtreecommitdiff
path: root/dev-lua/luaposix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-09-13 23:42:32 +0200
committerKarel Kočí <cynerd@email.cz>2018-09-13 23:42:32 +0200
commitb19af87c5b49942893d86b0eeda5d30fb8d9b053 (patch)
tree0e26231fc3ac8749439250c182a8ce85a720f255 /dev-lua/luaposix
parentebbb7e364a543e6aaf51d03b04a632bfd2ff289c (diff)
downloadgentoo-personal-overlay-b19af87c5b49942893d86b0eeda5d30fb8d9b053.tar.gz
gentoo-personal-overlay-b19af87c5b49942893d86b0eeda5d30fb8d9b053.tar.bz2
gentoo-personal-overlay-b19af87c5b49942893d86b0eeda5d30fb8d9b053.zip
luaposix: try to compile for multilib
Diffstat (limited to 'dev-lua/luaposix')
-rw-r--r--dev-lua/luaposix/luaposix-33.4.0-r1.ebuild (renamed from dev-lua/luaposix/luaposix-33.4.0.ebuild)10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-lua/luaposix/luaposix-33.4.0.ebuild b/dev-lua/luaposix/luaposix-33.4.0-r1.ebuild
index 6fb73e9..bba50f2 100644
--- a/dev-lua/luaposix/luaposix-33.4.0.ebuild
+++ b/dev-lua/luaposix/luaposix-33.4.0-r1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit multilib-minimal
DESCRIPTION="Bindings for POSIX APIs"
HOMEPAGE="https://luaposix.github.io/luaposix/ https://github.com/luaposix/luaposix"
@@ -12,8 +13,13 @@ LICENSE="public-domain"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
-RDEPEND="dev-lang/lua:=
+RDEPEND="dev-lang/lua:=[${MULTILIB_USEDEP}]
dev-lua/lua-compat[bit32]"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
S="${WORKDIR}"/${PN}-release-v${PV}
+
+src_prepare() {
+ multilib_copy_sources
+}