summaryrefslogtreecommitdiff
path: root/dev-lua/luaposix/luaposix-33.4.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luaposix/luaposix-33.4.0-r1.ebuild')
-rw-r--r--dev-lua/luaposix/luaposix-33.4.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-lua/luaposix/luaposix-33.4.0-r1.ebuild b/dev-lua/luaposix/luaposix-33.4.0-r1.ebuild
new file mode 100644
index 0000000..bba50f2
--- /dev/null
+++ b/dev-lua/luaposix/luaposix-33.4.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit multilib-minimal
+
+DESCRIPTION="Bindings for POSIX APIs"
+HOMEPAGE="https://luaposix.github.io/luaposix/ https://github.com/luaposix/luaposix"
+SRC_URI="https://github.com/luaposix/luaposix/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-lang/lua:=[${MULTILIB_USEDEP}]
+ dev-lua/lua-compat[bit32]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S="${WORKDIR}"/${PN}-release-v${PV}
+
+src_prepare() {
+ multilib_copy_sources
+}