aboutsummaryrefslogtreecommitdiff
path: root/nixos.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos.nix')
-rw-r--r--nixos.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/nixos.nix b/nixos.nix
index ca4edd2..c642d80 100644
--- a/nixos.nix
+++ b/nixos.nix
@@ -20,11 +20,13 @@ in {
programs.zsh.promptInit = ""; # Disable default prompt as we have our own
programs.bash.interactiveShellInit = ''
- eval $(${pkgs.shellrc-bash}/bin/shellrc-bash)
+ eval $(/run/current-system/sw/bin/shellrc-bash)
'';
programs.zsh.interactiveShellInit = mkIf zshEnable ''
- eval $(${pkgs.shellrc-zsh}/bin/shellrc-zsh)
+ eval $(/run/current-system/sw/bin/shellrc-zsh)
'';
+
+ environment.systemPackages = with pkgs; [shellrc-bash] ++ (optional zshEnable shellrc-zsh);
})
];
}