aboutsummaryrefslogtreecommitdiff
path: root/nixos.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2023-03-23 16:55:48 +0100
committerKarel Kočí <cynerd@email.cz>2023-03-23 16:55:48 +0100
commit4e33d9f26e0544ff23963fda389559f6c7c78109 (patch)
tree25990ebc444bd4845b9b91f6a1c35fdbb01dceaf /nixos.nix
parent7be0acbb1cd6b6d3c4c3df95611cb86be4b46915 (diff)
downloadshellrc-4e33d9f26e0544ff23963fda389559f6c7c78109.tar.gz
shellrc-4e33d9f26e0544ff23963fda389559f6c7c78109.tar.bz2
shellrc-4e33d9f26e0544ff23963fda389559f6c7c78109.zip
nixos: include packages to get completion
Diffstat (limited to 'nixos.nix')
-rw-r--r--nixos.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/nixos.nix b/nixos.nix
index ca4edd2..c642d80 100644
--- a/nixos.nix
+++ b/nixos.nix
@@ -20,11 +20,13 @@ in {
programs.zsh.promptInit = ""; # Disable default prompt as we have our own
programs.bash.interactiveShellInit = ''
- eval $(${pkgs.shellrc-bash}/bin/shellrc-bash)
+ eval $(/run/current-system/sw/bin/shellrc-bash)
'';
programs.zsh.interactiveShellInit = mkIf zshEnable ''
- eval $(${pkgs.shellrc-zsh}/bin/shellrc-zsh)
+ eval $(/run/current-system/sw/bin/shellrc-zsh)
'';
+
+ environment.systemPackages = with pkgs; [shellrc-bash] ++ (optional zshEnable shellrc-zsh);
})
];
}