summaryrefslogtreecommitdiff
path: root/updater-ng/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'updater-ng/Makefile')
-rw-r--r--updater-ng/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index ac5cb88..6c65ab2 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -41,7 +41,7 @@ define Package/$(PKG_NAME)/install
$(INSTALL_DIR) $(1)/etc/updater/hook_preupdate
touch $(1)/etc/updater/hook_preupdate/.keep
$(INSTALL_DIR) $(1)/etc/updater/hook_postupdate
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/pkgupdate/hook_postupdate/update_alternatives.sh $(1)/etc/updater/hook_postupdate/update_alternatives.sh
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/pkgupdate/hook_postupdate/update_alternatives.sh $(1)/etc/updater/hook_postupdate/20_update_alternatives.sh
$(INSTALL_DIR) $(1)/etc/updater/hook_reboot_required
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/pkgupdate/hook_reboot_required/50-create-notification.sh $(1)/etc/updater/hook_reboot_required/50-create-notification.sh
@@ -59,8 +59,7 @@ endef
define Package/$(PKG_NAME)-supervisor
TITLE:=Next generation updater supervisor and its library
- DEPENDS:=+updater-ng +vixie-cron +python3-light +python3-uci +userlists +l10n_supported
- EXTRA_DEPENDS:=userlists (>=11)
+ DEPENDS:=+updater-ng +vixie-cron +python3-light +python3-uci +pkglists +l10n_supported
endef
define Py3Package/$(PKG_NAME)-supervisor/install