summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--updater-ng/Makefile5
-rw-r--r--updater-ng/files/turris.lua4
-rw-r--r--updater-ng/files/updater.config14
3 files changed, 10 insertions, 13 deletions
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index ac5cb88..6c65ab2 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -41,7 +41,7 @@ define Package/$(PKG_NAME)/install
$(INSTALL_DIR) $(1)/etc/updater/hook_preupdate
touch $(1)/etc/updater/hook_preupdate/.keep
$(INSTALL_DIR) $(1)/etc/updater/hook_postupdate
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/pkgupdate/hook_postupdate/update_alternatives.sh $(1)/etc/updater/hook_postupdate/update_alternatives.sh
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/pkgupdate/hook_postupdate/update_alternatives.sh $(1)/etc/updater/hook_postupdate/20_update_alternatives.sh
$(INSTALL_DIR) $(1)/etc/updater/hook_reboot_required
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/pkgupdate/hook_reboot_required/50-create-notification.sh $(1)/etc/updater/hook_reboot_required/50-create-notification.sh
@@ -59,8 +59,7 @@ endef
define Package/$(PKG_NAME)-supervisor
TITLE:=Next generation updater supervisor and its library
- DEPENDS:=+updater-ng +vixie-cron +python3-light +python3-uci +userlists +l10n_supported
- EXTRA_DEPENDS:=userlists (>=11)
+ DEPENDS:=+updater-ng +vixie-cron +python3-light +python3-uci +pkglists +l10n_supported
endef
define Py3Package/$(PKG_NAME)-supervisor/install
diff --git a/updater-ng/files/turris.lua b/updater-ng/files/turris.lua
index 7071461..7e90623 100644
--- a/updater-ng/files/turris.lua
+++ b/updater-ng/files/turris.lua
@@ -20,8 +20,8 @@ end
local mode = uci_cnf("mode", "branch") -- should we follow branch or version?
local branch = uci_cnf("branch", "hbs") -- which branch to follow
local version = uci_cnf("version", nil) -- which version to follow
-local lists = uci_cnf("lists", {}) -- what additional lists should we use
-minimal_builds = uci_cnf("use_minimal", false) -- if packages-minimal should be used
+local lists = uci_cnf("pkglists", {}) -- what additional lists should we use
+minimal_builds = uci_cnf("use_minimal", "0") == "1" -- if packages-minimal should be used
Export('minimal_builds')
-- Verify that we have sensible configuration
diff --git a/updater-ng/files/updater.config b/updater-ng/files/updater.config
index 4bc05ed..f8b8bda 100644
--- a/updater-ng/files/updater.config
+++ b/updater-ng/files/updater.config
@@ -1,9 +1,7 @@
-config pkglists pkglists
- list lists 'cacerts'
- list lists 'luci-controls'
- list lists 'nas'
- list lists 'netutils'
-config l10n 'l10n'
- list langs 'cs'
- list langs 'de'
+config autorun 'autorun'
+ option enabled '0'
+
+config turris 'turris'
+ option mode 'branch'
+