summaryrefslogtreecommitdiff
path: root/personal-pkgs-repo
diff options
context:
space:
mode:
Diffstat (limited to 'personal-pkgs-repo')
-rw-r--r--personal-pkgs-repo/files/autopkg-branch.mk24
-rw-r--r--personal-pkgs-repo/files/autopkg-head.mk21
-rw-r--r--personal-pkgs-repo/files/autopkg-tag.mk8
-rw-r--r--personal-pkgs-repo/files/autopkg-tail.mk13
4 files changed, 0 insertions, 66 deletions
diff --git a/personal-pkgs-repo/files/autopkg-branch.mk b/personal-pkgs-repo/files/autopkg-branch.mk
deleted file mode 100644
index c8791cc..0000000
--- a/personal-pkgs-repo/files/autopkg-branch.mk
+++ /dev/null
@@ -1,24 +0,0 @@
-# Autopkg tracking given branch
-AUTOPKG_VARIANT:=branch
-$(call include_mk, autopkg-head.mk)
-
-ifndef PKG_SOURCE_BRANCH
-$(error You have to define PKG_SOURCE_BRANCH before pkgauto.mk include)
-endif
-
-PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) rev-parse "$(PKG_SOURCE_BRANCH)")
-PKG_VERSION:=$(shell git $(GIT_ARGS) describe --abbrev=0 --tags "$(PKG_SOURCE_BRANCH)")
-
-ifeq ($(PKG_VERSION),)
-# Count commits since initial commit.
-PKG_RELEASE:=$(shell git $(GIT_ARGS) rev-list --count "$(PKG_SOURCE_VERSION)")
-# No previous version found (no tag) so we use 9999 instead
-PKG_VERSION:=9999
-else
-# Count commits since last version tag
-PKG_RELEASE:=$(shell git $(GIT_ARGS) rev-list --count "$(PKG_VERSION)..$(PKG_SOURCE_VERSION)")
-# .9999 is appended to not collide with possible existing package versions in repository
-PKG_VERSION:=$(PKG_VERSION:v%=%).9999
-endif
-
-$(call include_mk, autopkg-tail.mk)
diff --git a/personal-pkgs-repo/files/autopkg-head.mk b/personal-pkgs-repo/files/autopkg-head.mk
deleted file mode 100644
index 115e1ae..0000000
--- a/personal-pkgs-repo/files/autopkg-head.mk
+++ /dev/null
@@ -1,21 +0,0 @@
-ifndef AUTOPKG_VARIANT
- $(error "Don't include autopkg-head.mk directly!")
-endif
-
-ifndef PKG_NAME
-$(error You have to define PKG_NAME before pkgauto.mk include)
-endif
-ifndef PKG_SOURCE_URL
-$(error You have to define PKG_SOURCE_URL before pkgauto.mk include)
-endif
-
-TMP_REPO_PATH=$(DL_DIR)/autopkg/$(PKG_NAME)
-GIT_ARGS=--git-dir='$(TMP_REPO_PATH)' --bare
-
-# Clone/update git history to bare repository
-$(shell \
- if [ ! -d "$(TMP_REPO_PATH)" ]; then \
- git clone --mirror "$(PKG_SOURCE_URL)" "$(TMP_REPO_PATH)"; \
- else \
- git $(GIT_ARGS) remote update origin; \
- fi)
diff --git a/personal-pkgs-repo/files/autopkg-tag.mk b/personal-pkgs-repo/files/autopkg-tag.mk
deleted file mode 100644
index 077c7ad..0000000
--- a/personal-pkgs-repo/files/autopkg-tag.mk
+++ /dev/null
@@ -1,8 +0,0 @@
-# Autopkg tracking latest version tag
-AUTOPKG_VARIANT:=tag
-$(call include_mk, autopkg-head.mk)
-
-PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) tag | grep '^v' | sort | tail -1)
-PKG_VERSION:=$(subst v%,%,$(PKG_SOURCE_VERSION))
-
-$(call include_mk, autopkg-tail.mk)
diff --git a/personal-pkgs-repo/files/autopkg-tail.mk b/personal-pkgs-repo/files/autopkg-tail.mk
deleted file mode 100644
index 3b6d104..0000000
--- a/personal-pkgs-repo/files/autopkg-tail.mk
+++ /dev/null
@@ -1,13 +0,0 @@
-ifndef AUTOPKG_VARIANT
- $(error "Don't include autopkg-tail.mk directly!")
-endif
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
-
-undefine TMP_REPO_PATH
-undefine GIT_ARGS
-undefine AUTOPKG_TAIL