summaryrefslogtreecommitdiff
path: root/personal-pkgs-repo/files/autopkg-head.mk
diff options
context:
space:
mode:
Diffstat (limited to 'personal-pkgs-repo/files/autopkg-head.mk')
-rw-r--r--personal-pkgs-repo/files/autopkg-head.mk21
1 files changed, 0 insertions, 21 deletions
diff --git a/personal-pkgs-repo/files/autopkg-head.mk b/personal-pkgs-repo/files/autopkg-head.mk
deleted file mode 100644
index 115e1ae..0000000
--- a/personal-pkgs-repo/files/autopkg-head.mk
+++ /dev/null
@@ -1,21 +0,0 @@
-ifndef AUTOPKG_VARIANT
- $(error "Don't include autopkg-head.mk directly!")
-endif
-
-ifndef PKG_NAME
-$(error You have to define PKG_NAME before pkgauto.mk include)
-endif
-ifndef PKG_SOURCE_URL
-$(error You have to define PKG_SOURCE_URL before pkgauto.mk include)
-endif
-
-TMP_REPO_PATH=$(DL_DIR)/autopkg/$(PKG_NAME)
-GIT_ARGS=--git-dir='$(TMP_REPO_PATH)' --bare
-
-# Clone/update git history to bare repository
-$(shell \
- if [ ! -d "$(TMP_REPO_PATH)" ]; then \
- git clone --mirror "$(PKG_SOURCE_URL)" "$(TMP_REPO_PATH)"; \
- else \
- git $(GIT_ARGS) remote update origin; \
- fi)