summaryrefslogtreecommitdiff
path: root/shellrc
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-08-30 09:36:18 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-08-30 09:36:18 +0200
commit1db7cfbb11e7f03fb3faa8837762797f5c3848dc (patch)
tree2389110ae1a2b9ab955146cf3c8a8a43d38d1336 /shellrc
parent15115cc35dc123405cc3dee00d6814945797b2a6 (diff)
downloadopenwrt-personal-pkgs-1db7cfbb11e7f03fb3faa8837762797f5c3848dc.tar.gz
openwrt-personal-pkgs-1db7cfbb11e7f03fb3faa8837762797f5c3848dc.tar.bz2
openwrt-personal-pkgs-1db7cfbb11e7f03fb3faa8837762797f5c3848dc.zip
Revert "Temporally drop all advanced packages"
This reverts commit 15115cc35dc123405cc3dee00d6814945797b2a6.
Diffstat (limited to 'shellrc')
-rw-r--r--shellrc/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/shellrc/Makefile b/shellrc/Makefile
new file mode 100644
index 0000000..628dd9f
--- /dev/null
+++ b/shellrc/Makefile
@@ -0,0 +1,58 @@
+#
+## Copyright (C) 2018 Karel Kočí
+#
+## This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# #
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=shellrc
+PKG_RELEASE:=1
+PKG_SOURCE_URL:=https://git.cynerd.cz/shellrc
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+
+$(call include_mk, autopkg-tag.mk)
+include $(INCLUDE_DIR)/package.mk
+
+define Package/$(PKG_NAME)
+ TITLE:=Shell initialization files
+endef
+
+define Package/$(PKG_NAME)-bash
+ TITLE:=Shell initialization files bash specific
+ DEPENDS:=$(PKG_NAME) bash
+endef
+
+define Package/$(PKG_NAME)-zsh
+ TITLE:=Shell initialization files zsh specific
+ DEPENDS:=$(PKG_NAME) zsh
+endef
+
+define Package/$(PKG_NAME)-ash
+ TITLE:=Shell initialization files ash specific
+ DEPENDS:=$(PKG_NAME)
+endef
+
+define Build/Compile
+ true
+endef
+
+define Package/$(PKG_NAME)/install
+ $(PKG_BUILD_DIR)/install --prefix "$(1)"
+endef
+
+define Package/$(PKG_NAME)-bash/install
+ $(PKG_BUILD_DIR)/install --prefix "$(1)" --bash --no-base
+endef
+
+define Package/$(PKG_NAME)-zsh/install
+ $(PKG_BUILD_DIR)/install --prefix "$(1)" --zsh --no-base
+endef
+
+define Package/$(PKG_NAME)-ash/install
+ # TODO
+ #$(PKG_BUILD_DIR)/install --prefix "$(1)" --ash --no-base
+endef
+
+$(eval $(call BuildPackage,$(PKG_NAME)))