summaryrefslogtreecommitdiff
path: root/shellrc
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-08-26 18:19:56 +0200
committerKarel Kočí <cynerd@email.cz>2018-08-26 18:25:25 +0200
commit15115cc35dc123405cc3dee00d6814945797b2a6 (patch)
tree11838d70c6208ddee9eb4d49cbc108c984061be3 /shellrc
parentf0078ea2da06440e53f799ce49afcda686defa34 (diff)
downloadopenwrt-personal-pkgs-15115cc35dc123405cc3dee00d6814945797b2a6.tar.gz
openwrt-personal-pkgs-15115cc35dc123405cc3dee00d6814945797b2a6.tar.bz2
openwrt-personal-pkgs-15115cc35dc123405cc3dee00d6814945797b2a6.zip
Temporally drop all advanced packages
Diffstat (limited to 'shellrc')
-rw-r--r--shellrc/Makefile58
1 files changed, 0 insertions, 58 deletions
diff --git a/shellrc/Makefile b/shellrc/Makefile
deleted file mode 100644
index 628dd9f..0000000
--- a/shellrc/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-#
-## Copyright (C) 2018 Karel Kočí
-#
-## This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-# #
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=shellrc
-PKG_RELEASE:=1
-PKG_SOURCE_URL:=https://git.cynerd.cz/shellrc
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-
-$(call include_mk, autopkg-tag.mk)
-include $(INCLUDE_DIR)/package.mk
-
-define Package/$(PKG_NAME)
- TITLE:=Shell initialization files
-endef
-
-define Package/$(PKG_NAME)-bash
- TITLE:=Shell initialization files bash specific
- DEPENDS:=$(PKG_NAME) bash
-endef
-
-define Package/$(PKG_NAME)-zsh
- TITLE:=Shell initialization files zsh specific
- DEPENDS:=$(PKG_NAME) zsh
-endef
-
-define Package/$(PKG_NAME)-ash
- TITLE:=Shell initialization files ash specific
- DEPENDS:=$(PKG_NAME)
-endef
-
-define Build/Compile
- true
-endef
-
-define Package/$(PKG_NAME)/install
- $(PKG_BUILD_DIR)/install --prefix "$(1)"
-endef
-
-define Package/$(PKG_NAME)-bash/install
- $(PKG_BUILD_DIR)/install --prefix "$(1)" --bash --no-base
-endef
-
-define Package/$(PKG_NAME)-zsh/install
- $(PKG_BUILD_DIR)/install --prefix "$(1)" --zsh --no-base
-endef
-
-define Package/$(PKG_NAME)-ash/install
- # TODO
- #$(PKG_BUILD_DIR)/install --prefix "$(1)" --ash --no-base
-endef
-
-$(eval $(call BuildPackage,$(PKG_NAME)))