summaryrefslogtreecommitdiff
path: root/python-pyusb
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-03-11 12:47:01 +0100
committerKarel Kočí <cynerd@email.cz>2022-03-11 12:47:01 +0100
commit4e2388f8435acd012cc480686c80f70d3358d513 (patch)
treecb7720a5daa9db72145497e849f325fd0146b24c /python-pyusb
parent549ec4d32ef9df05f27eaa15b1314f7708b6616f (diff)
downloadopenwrt-personal-pkgs-4e2388f8435acd012cc480686c80f70d3358d513.tar.gz
openwrt-personal-pkgs-4e2388f8435acd012cc480686c80f70d3358d513.tar.bz2
openwrt-personal-pkgs-4e2388f8435acd012cc480686c80f70d3358d513.zip
bigclown-firmware-tool: update to newer version
Diffstat (limited to 'python-pyusb')
-rw-r--r--python-pyusb/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/python-pyusb/Makefile b/python-pyusb/Makefile
new file mode 100644
index 0000000..f1535ff
--- /dev/null
+++ b/python-pyusb/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2022 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pyusb
+PKG_VERSION:=1.2.1
+PKG_RELEASE:=1
+
+PKG_LICENSE:=BSD
+PKG_LICENSE_FILES:=LICENSE
+
+PYPI_NAME:=pyusb
+PKG_HASH:=a4cc7404a203144754164b8b40994e2849fde1cfff06b08492f12fff9d9de7b9
+
+include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-pyusb
+ SECTION:=lang-python
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=USB access
+ URL:=https://pypi.org/project/pyusb/
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-pyusb/description
+ PyUSB offers easy USB devices communication in Python.
+endef
+
+$(eval $(call Py3Package,python3-pyusb))
+$(eval $(call BuildPackage,python3-pyusb))
+$(eval $(call BuildPackage,python3-pyusb-src))