summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-03-11 12:47:01 +0100
committerKarel Kočí <cynerd@email.cz>2022-03-11 12:47:01 +0100
commit4e2388f8435acd012cc480686c80f70d3358d513 (patch)
treecb7720a5daa9db72145497e849f325fd0146b24c
parent549ec4d32ef9df05f27eaa15b1314f7708b6616f (diff)
downloadopenwrt-personal-pkgs-4e2388f8435acd012cc480686c80f70d3358d513.tar.gz
openwrt-personal-pkgs-4e2388f8435acd012cc480686c80f70d3358d513.tar.bz2
openwrt-personal-pkgs-4e2388f8435acd012cc480686c80f70d3358d513.zip
bigclown-firmware-tool: update to newer version
-rw-r--r--bigclown-firmware-tool/Makefile7
-rw-r--r--python-ftdi/Makefile42
-rw-r--r--python-pyusb/Makefile40
3 files changed, 86 insertions, 3 deletions
diff --git a/bigclown-firmware-tool/Makefile b/bigclown-firmware-tool/Makefile
index f6fdb0a..177702a 100644
--- a/bigclown-firmware-tool/Makefile
+++ b/bigclown-firmware-tool/Makefile
@@ -5,11 +5,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bigclown-firmware-tool
-PKG_VERSION:=1.7.0
+PKG_VERSION:=1.8.1
PKG_RELEASE:=1
PYPI_NAME:=bcf
-PKG_HASH:=cf7ceabfa7377957391f71b4dff884d54943993944bfe1b96eccee4f67ce85ac
+PKG_HASH:=e88c5f83bc76f2943c7fae140c408c6a7aba315eb1fdbd1fa3b07be23a1d433d
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
PKG_LICENSE:=MIT
@@ -33,7 +33,8 @@ define Package/bigclown-firmware-tool
+python3-schema \
+python3-requests \
+python3-click \
- +python3-intelhex
+ +python3-intelhex \
+ +python3-pyftdi
endef
$(eval $(call Py3Package,bigclown-firmware-tool))
diff --git a/python-ftdi/Makefile b/python-ftdi/Makefile
new file mode 100644
index 0000000..25cd38e
--- /dev/null
+++ b/python-ftdi/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2022 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pyftdi
+PKG_VERSION:=0.53.3
+PKG_RELEASE:=1
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+PYPI_NAME:=pyftdi
+PKG_HASH:=4ef20c246bdb0f278d283337d7a6e69cf9bdb0ead525e7ad867d9e46ad26e613
+
+include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-pyftdi
+ SECTION:=lang-python
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=FTDI device driver
+ URL:=http://github.com/eblot/pyftdi
+ DEPENDS:=+python3-light \
+ +python3-pyusb \
+ +python3-pyserial
+ VARIANT:=python3
+endef
+
+define Package/python3-pyftdi/description
+ FTDI device driver (pure Python)
+endef
+
+$(eval $(call Py3Package,python3-pyftdi))
+$(eval $(call BuildPackage,python3-pyftdi))
+$(eval $(call BuildPackage,python3-pyftdi-src))
diff --git a/python-pyusb/Makefile b/python-pyusb/Makefile
new file mode 100644
index 0000000..f1535ff
--- /dev/null
+++ b/python-pyusb/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2022 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pyusb
+PKG_VERSION:=1.2.1
+PKG_RELEASE:=1
+
+PKG_LICENSE:=BSD
+PKG_LICENSE_FILES:=LICENSE
+
+PYPI_NAME:=pyusb
+PKG_HASH:=a4cc7404a203144754164b8b40994e2849fde1cfff06b08492f12fff9d9de7b9
+
+include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-pyusb
+ SECTION:=lang-python
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=USB access
+ URL:=https://pypi.org/project/pyusb/
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-pyusb/description
+ PyUSB offers easy USB devices communication in Python.
+endef
+
+$(eval $(call Py3Package,python3-pyusb))
+$(eval $(call BuildPackage,python3-pyusb))
+$(eval $(call BuildPackage,python3-pyusb-src))