summaryrefslogtreecommitdiff
path: root/personal-pkgs-repo
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-09-27 14:22:47 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-09-27 14:22:47 +0200
commit4590192d8d8be49549f1dddf9f70ec0b5e72cfe3 (patch)
tree2589d89676034ac15b423269224d91f0cb7ae63b /personal-pkgs-repo
parent9daf08fb38bd0857af79c12bfba14ad1a873ad95 (diff)
downloadopenwrt-personal-pkgs-4590192d8d8be49549f1dddf9f70ec0b5e72cfe3.tar.gz
openwrt-personal-pkgs-4590192d8d8be49549f1dddf9f70ec0b5e72cfe3.tar.bz2
openwrt-personal-pkgs-4590192d8d8be49549f1dddf9f70ec0b5e72cfe3.zip
personal-pkgs-repo: try to fix compilation
Diffstat (limited to 'personal-pkgs-repo')
-rw-r--r--personal-pkgs-repo/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/personal-pkgs-repo/Makefile b/personal-pkgs-repo/Makefile
index a8d0c90..1a19c7a 100644
--- a/personal-pkgs-repo/Makefile
+++ b/personal-pkgs-repo/Makefile
@@ -32,18 +32,15 @@ define Package/$(PKG_NAME)/install
$(INSTALL_CONF) ./files/updater.lua $(1)/etc/updater/conf.d/personal-pkgs.lua
endef
+BOARD:=unknown
ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_turris-omnia")
-BOARD=omnia
-else
-ifeq ($(CONFIG_TARGET_PROFILE),"TURRIS")
-BOARD=turris
-else
-ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_cznic-mox")
-BOARD:=mox
-else
-$(error This repository does not support profile: $(CONFIG_TARGET_PROFILE))
+ BOARD:=omnia
endif
+ifeq ($(CONFIG_TARGET_PROFILE),"TURRIS")
+ BOARD:=turris
endif
+ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_cznic-mox")
+ BOARD:=mox
endif
define Package/$(PKG_NAME)/postinst