summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--personal-pkgs-repo/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/personal-pkgs-repo/Makefile b/personal-pkgs-repo/Makefile
index a8d0c90..1a19c7a 100644
--- a/personal-pkgs-repo/Makefile
+++ b/personal-pkgs-repo/Makefile
@@ -32,18 +32,15 @@ define Package/$(PKG_NAME)/install
$(INSTALL_CONF) ./files/updater.lua $(1)/etc/updater/conf.d/personal-pkgs.lua
endef
+BOARD:=unknown
ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_turris-omnia")
-BOARD=omnia
-else
-ifeq ($(CONFIG_TARGET_PROFILE),"TURRIS")
-BOARD=turris
-else
-ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_cznic-mox")
-BOARD:=mox
-else
-$(error This repository does not support profile: $(CONFIG_TARGET_PROFILE))
+ BOARD:=omnia
endif
+ifeq ($(CONFIG_TARGET_PROFILE),"TURRIS")
+ BOARD:=turris
endif
+ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_cznic-mox")
+ BOARD:=mox
endif
define Package/$(PKG_NAME)/postinst