summaryrefslogtreecommitdiff
path: root/personal-pkgs-repo
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-03-17 11:33:04 +0100
committerKarel Kočí <cynerd@email.cz>2020-03-17 11:33:04 +0100
commit2a8769c7db8fa731fb3652a3e9b33161e7aed553 (patch)
tree98b5b7136c4c75c8c82e364adf8ac8d6721d7c2e /personal-pkgs-repo
parent178871e34d3e5a4da66e469963ef2743f2a4a6df (diff)
downloadopenwrt-personal-pkgs-2a8769c7db8fa731fb3652a3e9b33161e7aed553.tar.gz
openwrt-personal-pkgs-2a8769c7db8fa731fb3652a3e9b33161e7aed553.tar.bz2
openwrt-personal-pkgs-2a8769c7db8fa731fb3652a3e9b33161e7aed553.zip
personal-pkgs-repo: do not configure opkg
I am not using opkg anyway so do not configure it. It complicates usage sometimes.
Diffstat (limited to 'personal-pkgs-repo')
-rw-r--r--personal-pkgs-repo/Makefile31
1 files changed, 1 insertions, 30 deletions
diff --git a/personal-pkgs-repo/Makefile b/personal-pkgs-repo/Makefile
index 14be668..d7c3b4c 100644
--- a/personal-pkgs-repo/Makefile
+++ b/personal-pkgs-repo/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=personal-pkgs-repo
-PKG_VERSION:=1.4.11
+PKG_VERSION:=1.5.0
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
@@ -19,40 +19,11 @@ define Package/$(PKG_NAME)
endef
define Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/etc/opkg/keys
$(INSTALL_DIR) $(1)/etc/updater/keys
- $(INSTALL_DATA) ./files/key.pub $(1)/etc/opkg/keys/6b76319bf5a9dc2
$(INSTALL_DATA) ./files/key.pub $(1)/etc/updater/keys/personal-pkgs.pub
$(INSTALL_DIR) $(1)/etc/updater/conf.d
$(INSTALL_CONF) ./files/updater.lua $(1)/etc/updater/conf.d/personal-pkgs.lua
-
- $(INSTALL_DIR) $(1)/etc/updater/opkg-ignore
- echo ' personal ' >$(1)/etc/updater/opkg-ignore/personal-pkgs
-endef
-
-BOARD:=unknown
-ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_turris-omnia")
- BOARD:=omnia
-endif
-ifeq ($(CONFIG_TARGET_PROFILE),"TURRIS")
- BOARD:=turris
-endif
-ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_cznic-mox")
- BOARD:=mox
-endif
-
-define Package/$(PKG_NAME)/postinst
-#!/bin/sh
-feedsfile="$$IPKG_INSTROOT/etc/opkg/customfeeds.conf"
-sed -i '/^src\/gz personal/d' "$$feedsfile"
-echo "src/gz personal https://cynerd.cz/repo/turris/hbd/$(BOARD)" >> "$$feedsfile"
-endef
-
-define Package/$(PKG_NAME)/prerm
-#!/bin/sh
-feedsfile="$$IPKG_INSTROOT/etc/opkg/customfeeds.conf"
-sed -i '/^src\/gz personal/d' "$$feedsfile"
endef
Build/Compile:=: