summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--personal-pkgs-repo/Makefile31
1 files changed, 1 insertions, 30 deletions
diff --git a/personal-pkgs-repo/Makefile b/personal-pkgs-repo/Makefile
index 14be668..d7c3b4c 100644
--- a/personal-pkgs-repo/Makefile
+++ b/personal-pkgs-repo/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=personal-pkgs-repo
-PKG_VERSION:=1.4.11
+PKG_VERSION:=1.5.0
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
@@ -19,40 +19,11 @@ define Package/$(PKG_NAME)
endef
define Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/etc/opkg/keys
$(INSTALL_DIR) $(1)/etc/updater/keys
- $(INSTALL_DATA) ./files/key.pub $(1)/etc/opkg/keys/6b76319bf5a9dc2
$(INSTALL_DATA) ./files/key.pub $(1)/etc/updater/keys/personal-pkgs.pub
$(INSTALL_DIR) $(1)/etc/updater/conf.d
$(INSTALL_CONF) ./files/updater.lua $(1)/etc/updater/conf.d/personal-pkgs.lua
-
- $(INSTALL_DIR) $(1)/etc/updater/opkg-ignore
- echo ' personal ' >$(1)/etc/updater/opkg-ignore/personal-pkgs
-endef
-
-BOARD:=unknown
-ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_turris-omnia")
- BOARD:=omnia
-endif
-ifeq ($(CONFIG_TARGET_PROFILE),"TURRIS")
- BOARD:=turris
-endif
-ifeq ($(CONFIG_TARGET_PROFILE),"DEVICE_cznic-mox")
- BOARD:=mox
-endif
-
-define Package/$(PKG_NAME)/postinst
-#!/bin/sh
-feedsfile="$$IPKG_INSTROOT/etc/opkg/customfeeds.conf"
-sed -i '/^src\/gz personal/d' "$$feedsfile"
-echo "src/gz personal https://cynerd.cz/repo/turris/hbd/$(BOARD)" >> "$$feedsfile"
-endef
-
-define Package/$(PKG_NAME)/prerm
-#!/bin/sh
-feedsfile="$$IPKG_INSTROOT/etc/opkg/customfeeds.conf"
-sed -i '/^src\/gz personal/d' "$$feedsfile"
endef
Build/Compile:=: