summaryrefslogtreecommitdiff
path: root/bigclown-gateway/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-09-12 17:18:42 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-09-12 17:25:25 +0200
commit40764118789f79f79e943a95b805db4e929ec5d7 (patch)
tree3245894722bcd065d12857360dd0df9b0d1ccae2 /bigclown-gateway/Makefile
parentdf3d314797ebc02e0e0ffcd3d53dcc7186964296 (diff)
downloadopenwrt-personal-pkgs-40764118789f79f79e943a95b805db4e929ec5d7.tar.gz
openwrt-personal-pkgs-40764118789f79f79e943a95b805db4e929ec5d7.tar.bz2
openwrt-personal-pkgs-40764118789f79f79e943a95b805db4e929ec5d7.zip
Tweak bigclown packages
Diffstat (limited to 'bigclown-gateway/Makefile')
-rw-r--r--bigclown-gateway/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
index 60f659a..1fb8937 100644
--- a/bigclown-gateway/Makefile
+++ b/bigclown-gateway/Makefile
@@ -1,14 +1,7 @@
-#
-## Copyright (C) 2016-2017 CZ.NIC z.s.p.o. (http://www.nic.cz/)
-#
-## This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-# #
-#
include $(TOPDIR)/rules.mk
PKG_NAME:=bigclown-gateway
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-gateway.git
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
@@ -22,17 +15,22 @@ define Package/$(PKG_NAME)
endef
define Py3Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) ./files/bcg $(1)/usr/bin/bcg
$(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_CONF) ./files/bc-gateway-usb-dongle.config $(1)/etc/config/bc-gateway-usb-dongle
+ $(INSTALL_CONF) ./files/config $(1)/etc/config/bigclown-gateway
$(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/bc-gateway-usb-dongle.init $(1)/etc/init.d/bc-gateway-usb-dongle.init
+ $(INSTALL_BIN) ./files/init $(1)/etc/init.d/bigclown-gateway
+ $(INSTALL_DIR) $(1)/etc/udev/rules.d
+ $(INSTALL_DATA) ./files/udev $(1)/etc/udev/rules.d/58-bigclown-usb-dongle.rules
endef
define Package/$(PKG_NAME)/conffiles
-/etc/config/bc-gateway-usb-dongle
+/etc/config/bigclown-gateway
endef
define Build/Compile
+ sed -i 's/@@VERSION@@/$(PKG_VERSION)/' "$(PKG_BUILD_DIR)/setup.py"
$(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
endef