summaryrefslogtreecommitdiff
path: root/bigclown-gateway
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-09-12 17:18:42 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-09-12 17:25:25 +0200
commit40764118789f79f79e943a95b805db4e929ec5d7 (patch)
tree3245894722bcd065d12857360dd0df9b0d1ccae2 /bigclown-gateway
parentdf3d314797ebc02e0e0ffcd3d53dcc7186964296 (diff)
downloadopenwrt-personal-pkgs-40764118789f79f79e943a95b805db4e929ec5d7.tar.gz
openwrt-personal-pkgs-40764118789f79f79e943a95b805db4e929ec5d7.tar.bz2
openwrt-personal-pkgs-40764118789f79f79e943a95b805db4e929ec5d7.zip
Tweak bigclown packages
Diffstat (limited to 'bigclown-gateway')
-rw-r--r--bigclown-gateway/Makefile20
-rwxr-xr-xbigclown-gateway/files/bcg9
-rw-r--r--bigclown-gateway/files/config (renamed from bigclown-gateway/files/bc-gateway-usb-dongle.config)0
-rwxr-xr-xbigclown-gateway/files/init (renamed from bigclown-gateway/files/bc-gateway-usb-dongle.init)16
-rw-r--r--bigclown-gateway/files/udev1
5 files changed, 26 insertions, 20 deletions
diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
index 60f659a..1fb8937 100644
--- a/bigclown-gateway/Makefile
+++ b/bigclown-gateway/Makefile
@@ -1,14 +1,7 @@
-#
-## Copyright (C) 2016-2017 CZ.NIC z.s.p.o. (http://www.nic.cz/)
-#
-## This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-# #
-#
include $(TOPDIR)/rules.mk
PKG_NAME:=bigclown-gateway
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-gateway.git
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
@@ -22,17 +15,22 @@ define Package/$(PKG_NAME)
endef
define Py3Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) ./files/bcg $(1)/usr/bin/bcg
$(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_CONF) ./files/bc-gateway-usb-dongle.config $(1)/etc/config/bc-gateway-usb-dongle
+ $(INSTALL_CONF) ./files/config $(1)/etc/config/bigclown-gateway
$(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/bc-gateway-usb-dongle.init $(1)/etc/init.d/bc-gateway-usb-dongle.init
+ $(INSTALL_BIN) ./files/init $(1)/etc/init.d/bigclown-gateway
+ $(INSTALL_DIR) $(1)/etc/udev/rules.d
+ $(INSTALL_DATA) ./files/udev $(1)/etc/udev/rules.d/58-bigclown-usb-dongle.rules
endef
define Package/$(PKG_NAME)/conffiles
-/etc/config/bc-gateway-usb-dongle
+/etc/config/bigclown-gateway
endef
define Build/Compile
+ sed -i 's/@@VERSION@@/$(PKG_VERSION)/' "$(PKG_BUILD_DIR)/setup.py"
$(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
endef
diff --git a/bigclown-gateway/files/bcg b/bigclown-gateway/files/bcg
new file mode 100755
index 0000000..fe261f4
--- /dev/null
+++ b/bigclown-gateway/files/bcg
@@ -0,0 +1,9 @@
+#!/usr/bin/python3.6
+import bcg
+import sys
+from pkg_resources import load_entry_point
+
+if __name__ == '__main__':
+ sys.exit(
+ load_entry_point('bcg', 'console_scripts', 'bcg')()
+ )
diff --git a/bigclown-gateway/files/bc-gateway-usb-dongle.config b/bigclown-gateway/files/config
index 7fa3977..7fa3977 100644
--- a/bigclown-gateway/files/bc-gateway-usb-dongle.config
+++ b/bigclown-gateway/files/config
diff --git a/bigclown-gateway/files/bc-gateway-usb-dongle.init b/bigclown-gateway/files/init
index bae6d11..090cc06 100755
--- a/bigclown-gateway/files/bc-gateway-usb-dongle.init
+++ b/bigclown-gateway/files/init
@@ -1,16 +1,12 @@
#!/bin/sh /etc/rc.common
-START=99
+START=98
STOP=1
USE_PROCD=1
PROG=/usr/bin/bcg
-
-CONF=/tmp/bc-gateway-usb-dongle.generated.conf
-
-UCI_STARTED=
-UCI_DISABLED=
+CONF=/tmp/etc/bigclown-gateway.conf
append() {
local cfg="$1"
@@ -24,18 +20,18 @@ append() {
}
start_service() {
- config_load bc-gateway-usb-dongle
+ config_load bigclown-gateway
rm -rf $CONF
- echo "Generating bc-gateway-usb-dongle config file in $CONF"
+ echo "Generating bigclown-gateway config file in $CONF"
append gateway name 'name:' usb-dongle
+ # TODO add udev rules and use different default here
append gateway device 'device:' /dev/ttyUSB0
append gateway automatic_rename_kit_nodes 'automatic_rename_kit_nodes:' 1
append gateway base_topic_prefix 'base_topic_prefix:'
echo "mqtt:" >> $CONF
-
append mqtt host ' host:' localhost
append mqtt port ' port:' 1883
append mqtt cafile ' cafile:'
@@ -45,6 +41,8 @@ start_service() {
procd_open_instance
procd_set_param respawn
procd_set_param command "$PROG" -c "$CONF" -W
+ procd_set_param stdout 1
+ procd_set_param stderr 1
procd_close_instance
}
diff --git a/bigclown-gateway/files/udev b/bigclown-gateway/files/udev
new file mode 100644
index 0000000..d7a854b
--- /dev/null
+++ b/bigclown-gateway/files/udev
@@ -0,0 +1 @@
+SUBSYSTEMS=="usb", ACTION=="add", KERNEL=="ttyUSB*", ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6015", ATTRS{serial}=="bc-usb-dongle*", SYMLINK+="bcUD%n", TAG+="systemd", ENV{SYSTEMD_ALIAS}="/dev/bcUD%n"