summaryrefslogtreecommitdiff
path: root/bigclown-firmware-tool
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-05-10 16:49:11 +0200
committerKarel Kočí <cynerd@email.cz>2021-05-10 16:49:11 +0200
commitef7468756e2e509c3972b95da934a02173c34a0a (patch)
tree457262546b67a2956a14fa8f0766454e38d3e0cb /bigclown-firmware-tool
parentac0953a3d5787da078e1026f077184f70a4c91c3 (diff)
downloadopenwrt-personal-pkgs-ef7468756e2e509c3972b95da934a02173c34a0a.tar.gz
openwrt-personal-pkgs-ef7468756e2e509c3972b95da934a02173c34a0a.tar.bz2
openwrt-personal-pkgs-ef7468756e2e509c3972b95da934a02173c34a0a.zip
Add bigclown packages for testing
Diffstat (limited to 'bigclown-firmware-tool')
-rw-r--r--bigclown-firmware-tool/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/bigclown-firmware-tool/Makefile b/bigclown-firmware-tool/Makefile
new file mode 100644
index 0000000..2d5446c
--- /dev/null
+++ b/bigclown-firmware-tool/Makefile
@@ -0,0 +1,40 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bigclown-firmware-tool
+PKG_VERSION:=1.7.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=bcf
+PKG_HASH:=cf7ceabfa7377957391f71b4dff884d54943993944bfe1b96eccee4f67ce85ac
+
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../../../lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../../../lang/python/python3-package.mk
+
+define Package/bigclown-firmware-tool
+ SECTION:=utils
+ CATEGORY:=Utilities
+ SUBMENU:=BigClown
+ TITLE:=BigCLown firmware tool
+ URL:=https://github.com/bigclownlabs/bch-firmware-tool
+ DEPENDS:= \
+ +python3-appdirs \
+ +python3-pyserial \
+ +python3-colorama \
+ +python3-yaml \
+ +python3-schema \
+ +python3-requests \
+ +python3-click \
+ +python3-intelhex
+endef
+
+$(eval $(call Py3Package,bigclown-firmware-tool))
+$(eval $(call BuildPackage,bigclown-firmware-tool))