summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-05-10 16:49:11 +0200
committerKarel Kočí <cynerd@email.cz>2021-05-10 16:49:11 +0200
commitef7468756e2e509c3972b95da934a02173c34a0a (patch)
tree457262546b67a2956a14fa8f0766454e38d3e0cb
parentac0953a3d5787da078e1026f077184f70a4c91c3 (diff)
downloadopenwrt-personal-pkgs-ef7468756e2e509c3972b95da934a02173c34a0a.tar.gz
openwrt-personal-pkgs-ef7468756e2e509c3972b95da934a02173c34a0a.tar.bz2
openwrt-personal-pkgs-ef7468756e2e509c3972b95da934a02173c34a0a.zip
Add bigclown packages for testing
-rw-r--r--bigclown-control-tool/Makefile38
-rw-r--r--bigclown-firmware-tool/Makefile40
-rw-r--r--bigclown-gateway/Makefile56
-rw-r--r--bigclown-gateway/files/config10
-rwxr-xr-xbigclown-gateway/files/init63
5 files changed, 207 insertions, 0 deletions
diff --git a/bigclown-control-tool/Makefile b/bigclown-control-tool/Makefile
new file mode 100644
index 0000000..d624f6d
--- /dev/null
+++ b/bigclown-control-tool/Makefile
@@ -0,0 +1,38 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bigclown-control-tool
+PKG_VERSION:=1.1.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=bch
+PKG_HASH:=7af9471c4f9d5593aae2606ea59dcf5f1a1635117dd51d19fb623f8b4080777a
+
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../../../lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../../../lang/python/python3-package.mk
+
+define Package/bigclown-control-tool
+ SECTION:=utils
+ CATEGORY:=Utilities
+ SUBMENU:=BigClown
+ TITLE:=BigCLown control tool
+ URL:=https://github.com/bigclownlabs/bch-control-tool
+ DEPENDS:=\
+ +python3-click \
+ +python3-click-log \
+ +python3-paho-mqtt \
+ +python3-pyserial \
+ +python3-yaml \
+ +python3-simplejson
+endef
+
+$(eval $(call Py3Package,bigclown-control-tool))
+$(eval $(call BuildPackage,bigclown-control-tool))
diff --git a/bigclown-firmware-tool/Makefile b/bigclown-firmware-tool/Makefile
new file mode 100644
index 0000000..2d5446c
--- /dev/null
+++ b/bigclown-firmware-tool/Makefile
@@ -0,0 +1,40 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bigclown-firmware-tool
+PKG_VERSION:=1.7.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=bcf
+PKG_HASH:=cf7ceabfa7377957391f71b4dff884d54943993944bfe1b96eccee4f67ce85ac
+
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../../../lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../../../lang/python/python3-package.mk
+
+define Package/bigclown-firmware-tool
+ SECTION:=utils
+ CATEGORY:=Utilities
+ SUBMENU:=BigClown
+ TITLE:=BigCLown firmware tool
+ URL:=https://github.com/bigclownlabs/bch-firmware-tool
+ DEPENDS:= \
+ +python3-appdirs \
+ +python3-pyserial \
+ +python3-colorama \
+ +python3-yaml \
+ +python3-schema \
+ +python3-requests \
+ +python3-click \
+ +python3-intelhex
+endef
+
+$(eval $(call Py3Package,bigclown-firmware-tool))
+$(eval $(call BuildPackage,bigclown-firmware-tool))
diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
new file mode 100644
index 0000000..ece71ac
--- /dev/null
+++ b/bigclown-gateway/Makefile
@@ -0,0 +1,56 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bigclown-gateway
+PKG_VERSION:=1.17.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=bcg
+PKG_HASH:=38a423952160e8cd468157af4a1fecec9f9c903de3309da277164ac14a421c58
+
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../../../lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../../../lang/python/python3-package.mk
+
+define Package/bigclown-gateway
+ SECTION:=utils
+ CATEGORY:=Utilities
+ SUBMENU:=BigClown
+ TITLE:=BigCLown gateway
+ URL:=https://github.com/bigclownlabs/bch-gateway
+ DEPENDS:= \
+ +kmod-usb-serial-ftdi \
+ +kmod-usb-acm \
+ +python3-click \
+ +python3-click-log \
+ +python3-paho-mqtt \
+ +python3-pyserial \
+ +python3-yaml \
+ +python3-simplejson \
+ +python3-schema \
+ +python3-appdirs
+endef
+
+define Py3Package/bigclown-gateway/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_CONF) ./files/config $(1)/etc/config/bigclown-gateway
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/init $(1)/etc/init.d/bigclown-gateway
+endef
+
+define Package/bigclown-gateway/conffiles
+/etc/config/bigclown-gateway
+endef
+
+$(eval $(call Py3Package,bigclown-gateway))
+$(eval $(call BuildPackage,bigclown-gateway))
diff --git a/bigclown-gateway/files/config b/bigclown-gateway/files/config
new file mode 100644
index 0000000..6a60ae4
--- /dev/null
+++ b/bigclown-gateway/files/config
@@ -0,0 +1,10 @@
+
+config gateway 'gateway'
+ option enabled '0'
+ option name 'usb-dongle'
+ option device '/dev/ttyUSB0'
+ option automatic_rename_kit_nodes '1'
+
+config mqtt 'mqtt'
+ option host 'localhost'
+ option port '1883'
diff --git a/bigclown-gateway/files/init b/bigclown-gateway/files/init
new file mode 100755
index 0000000..65c20e2
--- /dev/null
+++ b/bigclown-gateway/files/init
@@ -0,0 +1,63 @@
+#!/bin/sh /etc/rc.common
+
+START=98
+STOP=1
+
+USE_PROCD=1
+
+PROG=/usr/bin/bcg
+CONF=/tmp/etc/bigclown-gateway.conf
+
+append() {
+ local cfg="$1"
+ local uci_name="$2"
+ local out_name="$3"
+ local default="$4"
+ config_get val $cfg $uci_name $default
+ if [ -n "$val" ]; then
+ echo "$out_name $val" >> $CONF
+ fi
+}
+
+start_service() {
+ config_load bigclown-gateway
+
+ local enabled
+ config_get_bool enabled gateway enabled "0"
+ [ "$enabled" = "1" ] || {
+ echo "Bigclown gateway service disabled"
+ exit 1
+ }
+
+ rm -rf $CONF
+ echo "Generating bigclown-gateway config file in $CONF"
+
+ append gateway name 'name:' usb-dongle
+ # TODO add hotplug script and use different default here
+ append gateway device 'device:' /dev/ttyUSB0
+ append gateway automatic_remove_kit_from_names 'automatic_remove_kit_from_names:' 1
+ append gateway automatic_rename_kit_nodes 'automatic_rename_kit_nodes:' 1
+ append gateway automatic_rename_generic_nodes 'automatic_rename_generic_nodes:' 1
+ append gateway automatic_rename_nodes 'automatic_rename_nodes:' 1
+ append gateway base_topic_prefix 'base_topic_prefix:'
+
+ echo "mqtt:" >> $CONF
+ append mqtt host ' host:' localhost
+ append mqtt port ' port:' 1883
+ append mqtt username ' username:'
+ append mqtt password ' password:'
+ append mqtt cafile ' cafile:'
+ append mqtt certfile ' certfile:'
+ append mqtt keyfile ' keyfile:'
+
+ procd_open_instance
+ procd_set_param respawn
+ procd_set_param command "$PROG" -c "$CONF"
+ procd_set_param stdout 1
+ procd_set_param stderr 1
+ procd_close_instance
+}
+
+service_triggers() {
+ procd_add_reload_trigger 'bigclown-gateway'
+}