summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-02-04 11:56:25 +0100
committerKarel Kočí <cynerd@email.cz>2022-02-04 11:56:25 +0100
commit0ed3e2856a5700363e72c9bdfc993d453d409764 (patch)
treeede9c3b4558159a35c92fe8b4a27f99ba208db82
parentac4d8651c321aa474dedb78c32a379cd3b0b11d5 (diff)
downloadopenwrt-personal-pkgs-0ed3e2856a5700363e72c9bdfc993d453d409764.tar.gz
openwrt-personal-pkgs-0ed3e2856a5700363e72c9bdfc993d453d409764.tar.bz2
openwrt-personal-pkgs-0ed3e2856a5700363e72c9bdfc993d453d409764.zip
turris-bootstrap-theme: add package
-rw-r--r--turris-bootstrap-theme/Makefile51
-rw-r--r--turris-bootstrap-theme/files/lighttpd.conf3
-rw-r--r--updater-supervisor/Makefile2
3 files changed, 55 insertions, 1 deletions
diff --git a/turris-bootstrap-theme/Makefile b/turris-bootstrap-theme/Makefile
new file mode 100644
index 0000000..05e0a39
--- /dev/null
+++ b/turris-bootstrap-theme/Makefile
@@ -0,0 +1,51 @@
+#
+## Copyright (C) 2021-2022 CZ.NIC z.s.p.o. (https://www.nic.cz/)
+#
+## This is free software, licensed under the GNU General Public License v3.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=turris-bootstrap-theme
+PKG_VERSION:=0.3.0
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/bootstrap-theme.git
+PKG_MIRROR_HASH:=b83cba622f3d3d9ab532f3b7ef79826dc4fa28c7151658cd0b28bae990ed9267
+PKG_SOURCE_VERSION:=v$(PKG_VERSION)
+
+PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/turris-bootstrap-theme
+ SECTION:=web
+ CATEGORY:=Web
+ TITLE:=Turris Bootstrap Theme
+ DEPENDS:=+lighttpd +lighttpd-mod-alias
+endef
+
+define Package/turris-bootstrap-theme/description
+ Common Turris-specific bootstrap theme.
+endef
+
+Build/Compile:=:
+
+define Package/turris-bootstrap-theme/install
+ $(INSTALL_DIR) $(1)/etc/lighttpd/conf.d
+ $(INSTALL_CONF) ./files/lighttpd.conf $(1)/etc/lighttpd/conf.d/theme.conf
+
+ $(INSTALL_DIR) $(1)/www/turris-theme
+ $(MAKE) -C $(PKG_BUILD_DIR) install NO_BUILD=y INSTALL_DIR=$(1)/www/turris-theme
+endef
+
+define Package/turris-bootstrap-theme/postinst
+#!/bin/sh
+[ -n "$$IPKG_INSTROOT" ] || /etc/init.d/lighttpd restart
+endef
+
+$(eval $(call BuildPackage,turris-bootstrap-theme))
diff --git a/turris-bootstrap-theme/files/lighttpd.conf b/turris-bootstrap-theme/files/lighttpd.conf
new file mode 100644
index 0000000..12fc677
--- /dev/null
+++ b/turris-bootstrap-theme/files/lighttpd.conf
@@ -0,0 +1,3 @@
+alias.url += (
+ "/turris-theme" => "/www/turris-theme"
+)
diff --git a/updater-supervisor/Makefile b/updater-supervisor/Makefile
index 594f3c9..421126f 100644
--- a/updater-supervisor/Makefile
+++ b/updater-supervisor/Makefile
@@ -25,7 +25,7 @@ define Package/updater-supervisor
DEPENDS:= \
+updater-ng +pkglists +l10n-supported \
+python3-light +python3-uci +python3-distro +python3-packaging \
- +cronie
+ +cronie +curl
VARIANT:=python3
endef