summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-01-26 21:34:45 +0100
committerKarel Kočí <cynerd@email.cz>2022-01-26 21:34:45 +0100
commitac4d8651c321aa474dedb78c32a379cd3b0b11d5 (patch)
tree232c221aa6a11add410d5c2129d0b4a79085dfc6
parent7aaa211601597aee58e56d99cf8530a7ba52d80c (diff)
downloadopenwrt-personal-pkgs-ac4d8651c321aa474dedb78c32a379cd3b0b11d5.tar.gz
openwrt-personal-pkgs-ac4d8651c321aa474dedb78c32a379cd3b0b11d5.tar.bz2
openwrt-personal-pkgs-ac4d8651c321aa474dedb78c32a379cd3b0b11d5.zip
updater-supervisor: development version
-rw-r--r--updater-supervisor/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/updater-supervisor/Makefile b/updater-supervisor/Makefile
new file mode 100644
index 0000000..594f3c9
--- /dev/null
+++ b/updater-supervisor/Makefile
@@ -0,0 +1,52 @@
+#
+## Copyright (C) 2019-2020 CZ.NIC z.s.p.o. (http://www.nic.cz/)
+#
+## This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# #
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=updater-supervisor
+PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/updater/supervisor.git
+PKG_SOURCE_BRANCH:=bugfix/changelog
+
+PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
+PKG_LICENSE:=MIT
+
+include $(INCLUDE_DIR)/autopkg-branch.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/updater-supervisor
+ SECTION:=updater
+ CATEGORY:=Turris Updater
+ TITLE:=Updater supervisor and its library
+ DEPENDS:= \
+ +updater-ng +pkglists +l10n-supported \
+ +python3-light +python3-uci +python3-distro +python3-packaging \
+ +cronie
+ VARIANT:=python3
+endef
+
+define Package/updater-supervisor/description
+ Python library and program wrapping execution of updater-ng's pkgupdate tool. It
+ integrates it to frontend and provides additional reporting mechanisms.
+ Secondary this also serves as universal configuration API for updater-ng.
+endef
+
+define Py3Package/updater-supervisor/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/files/immediate_reboot.init $(1)/etc/init.d/updater-journal-recover
+ $(INSTALL_DIR) $(1)/etc/cron.d
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/files/cron $(1)/etc/cron.d/updater
+ $(INSTALL_DIR) $(1)/etc/updater/hook_postupdate
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/files/hook_postupdate $(1)/etc/updater/hook_postupdate/99_approvals_cleanup
+endef
+
+$(eval $(call Py3Package,updater-supervisor))
+$(eval $(call BuildPackage,updater-supervisor))
+$(eval $(call BuildPackage,updater-supervisor-src))