aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/turris-defaults.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/turris-defaults.nix')
-rw-r--r--nixos/modules/turris-defaults.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/turris-defaults.nix b/nixos/modules/turris-defaults.nix
index 8799664..2f61827 100644
--- a/nixos/modules/turris-defaults.nix
+++ b/nixos/modules/turris-defaults.nix
@@ -30,8 +30,8 @@ in {
config = mkIf cnf.enable {
# We do not need Grub as U-Boot supports boot using extlinux like file
- boot.loader.grub.enable = false;
- boot.loader.generic-extlinux-compatible.enable = true;
+ boot.loader.grub.enable = mkDefault false;
+ boot.loader.generic-extlinux-compatible.enable = mkDefault true;
# Use early print to the serial console
boot.kernelParams = [
"boot.shell_on_fail"
@@ -43,7 +43,7 @@ in {
];
# Use the latest kernel
- boot.kernelPackages = pkgs.linuxPackages_latest;
+ boot.kernelPackages = mkDefault pkgs.linuxPackages_latest;
# The supported deployment is on BTRFS
boot.supportedFilesystems = [ "btrfs" ];