aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/turris-defaults.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-04-14 18:18:30 +0200
committerKarel Kočí <cynerd@email.cz>2022-04-14 18:18:30 +0200
commit94f863d84acb5340c3c999f1fa06678f7a5df9f5 (patch)
treeec38540ddd274d5a43661fccdcf229c111f883e0 /nixos/modules/turris-defaults.nix
parent51bda2b636e35a64b2ff25dd676d124f4b11b6e0 (diff)
downloadnixturris-94f863d84acb5340c3c999f1fa06678f7a5df9f5.tar.gz
nixturris-94f863d84acb5340c3c999f1fa06678f7a5df9f5.tar.bz2
nixturris-94f863d84acb5340c3c999f1fa06678f7a5df9f5.zip
nixos: add turris-wifi modules
Diffstat (limited to 'nixos/modules/turris-defaults.nix')
-rw-r--r--nixos/modules/turris-defaults.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/turris-defaults.nix b/nixos/modules/turris-defaults.nix
index 8799664..2f61827 100644
--- a/nixos/modules/turris-defaults.nix
+++ b/nixos/modules/turris-defaults.nix
@@ -30,8 +30,8 @@ in {
config = mkIf cnf.enable {
# We do not need Grub as U-Boot supports boot using extlinux like file
- boot.loader.grub.enable = false;
- boot.loader.generic-extlinux-compatible.enable = true;
+ boot.loader.grub.enable = mkDefault false;
+ boot.loader.generic-extlinux-compatible.enable = mkDefault true;
# Use early print to the serial console
boot.kernelParams = [
"boot.shell_on_fail"
@@ -43,7 +43,7 @@ in {
];
# Use the latest kernel
- boot.kernelPackages = pkgs.linuxPackages_latest;
+ boot.kernelPackages = mkDefault pkgs.linuxPackages_latest;
# The supported deployment is on BTRFS
boot.supportedFilesystems = [ "btrfs" ];