aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index ad1be3e..3f89719 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,11 +2,12 @@
description = "Turris flake";
outputs = { self, flake-utils, nixpkgs }:
+ with nixpkgs.lib;
with flake-utils.lib;
let
supportedHostSystems = (
# Note: crossTarball* targets are broken on darwin so it gets disabled here
- with builtins; filter (system: match ".*-darwin" system == null) defaultSystems
+ with builtins; filter (system: hasSuffix "-darwin" system) defaultSystems
) ++ [system.armv7l-linux];
in {