aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-11-01 09:44:59 +0100
committerKarel Kočí <cynerd@email.cz>2022-11-01 09:44:59 +0100
commit955268e13f8f9422e7e89ee6350ec793dddd1e94 (patch)
tree1714aa5f8383ddf5aaaf7826c8502f686bcd8a7a /flake.nix
parent06293bfbb5082dc636358d49f3e6fea88c4f2a67 (diff)
downloadnixturris-955268e13f8f9422e7e89ee6350ec793dddd1e94.tar.gz
nixturris-955268e13f8f9422e7e89ee6350ec793dddd1e94.tar.bz2
nixturris-955268e13f8f9422e7e89ee6350ec793dddd1e94.zip
nixos: try to fix Turris Omnia PCIe on Linux 6.0
Unfortunatelly this seems to not work.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index ad1be3e..3f89719 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,11 +2,12 @@
description = "Turris flake";
outputs = { self, flake-utils, nixpkgs }:
+ with nixpkgs.lib;
with flake-utils.lib;
let
supportedHostSystems = (
# Note: crossTarball* targets are broken on darwin so it gets disabled here
- with builtins; filter (system: match ".*-darwin" system == null) defaultSystems
+ with builtins; filter (system: hasSuffix "-darwin" system) defaultSystems
) ++ [system.armv7l-linux];
in {