aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/compile.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/compile.nix')
-rw-r--r--nixos/modules/compile.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/modules/compile.nix b/nixos/modules/compile.nix
index 929b373..3c90345 100644
--- a/nixos/modules/compile.nix
+++ b/nixos/modules/compile.nix
@@ -3,8 +3,9 @@
lib,
pkgs,
...
-}:
-with lib; {
+}: let
+ inherit (lib) mkOption mkIf mkDefault types;
+in {
options = {
cynerd.compile = mkOption {
type = types.bool;