aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/compile.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2024-01-16 17:00:20 +0100
committerKarel Kočí <cynerd@email.cz>2024-01-16 17:00:20 +0100
commitcfacd69575b5888bf3e054c9f8056a19c4b5903e (patch)
treea2f1c475ef872e95211bf648a5a0fe48965c66a0 /nixos/modules/compile.nix
parent55296b643fe2934b875561dd58861b69d4951e9c (diff)
downloadnixos-personal-cfacd69575b5888bf3e054c9f8056a19c4b5903e.tar.gz
nixos-personal-cfacd69575b5888bf3e054c9f8056a19c4b5903e.tar.bz2
nixos-personal-cfacd69575b5888bf3e054c9f8056a19c4b5903e.zip
Rework
Diffstat (limited to 'nixos/modules/compile.nix')
-rw-r--r--nixos/modules/compile.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/modules/compile.nix b/nixos/modules/compile.nix
index 929b373..3c90345 100644
--- a/nixos/modules/compile.nix
+++ b/nixos/modules/compile.nix
@@ -3,8 +3,9 @@
lib,
pkgs,
...
-}:
-with lib; {
+}: let
+ inherit (lib) mkOption mkIf mkDefault types;
+in {
options = {
cynerd.compile = mkOption {
type = types.bool;