aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/compile.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/compile.nix')
-rw-r--r--nixos/modules/compile.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/nixos/modules/compile.nix b/nixos/modules/compile.nix
new file mode 100644
index 0000000..a1709e6
--- /dev/null
+++ b/nixos/modules/compile.nix
@@ -0,0 +1,30 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ options = {
+ cynerd.compile = mkOption {
+ type = types.bool;
+ default = false;
+ description = "If machine is about to be used for compilation.";
+ };
+ };
+
+ config = mkIf config.cynerd.compile {
+
+ environment.systemPackages = with pkgs; [
+ # Tools
+ git bash
+ #uroot
+ qemu
+
+ # Python
+ python3Packages.pip
+
+ ];
+
+ };
+
+}