aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/compile.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-02-21 21:54:09 +0100
committerKarel Kočí <cynerd@email.cz>2022-06-10 14:05:48 +0200
commit93b0545d11bf8c7f065203f7f3eaf1d0e3730dce (patch)
treeda93fa5fcd14c493d8ccd86c98f40d26c9697869 /nixos/modules/compile.nix
downloadnixos-personal-93b0545d11bf8c7f065203f7f3eaf1d0e3730dce.tar.gz
nixos-personal-93b0545d11bf8c7f065203f7f3eaf1d0e3730dce.tar.bz2
nixos-personal-93b0545d11bf8c7f065203f7f3eaf1d0e3730dce.zip
Add initial version
Diffstat (limited to 'nixos/modules/compile.nix')
-rw-r--r--nixos/modules/compile.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/nixos/modules/compile.nix b/nixos/modules/compile.nix
new file mode 100644
index 0000000..a1709e6
--- /dev/null
+++ b/nixos/modules/compile.nix
@@ -0,0 +1,30 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ options = {
+ cynerd.compile = mkOption {
+ type = types.bool;
+ default = false;
+ description = "If machine is about to be used for compilation.";
+ };
+ };
+
+ config = mkIf config.cynerd.compile {
+
+ environment.systemPackages = with pkgs; [
+ # Tools
+ git bash
+ #uroot
+ qemu
+
+ # Python
+ python3Packages.pip
+
+ ];
+
+ };
+
+}