aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/mrpump.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/machine/mrpump.nix')
-rw-r--r--nixos/machine/mrpump.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/nixos/machine/mrpump.nix b/nixos/machine/mrpump.nix
new file mode 100644
index 0000000..818652c
--- /dev/null
+++ b/nixos/machine/mrpump.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ config = {
+ boot.isContainer = true;
+ boot.loader.initScript.enable = true;
+
+ # Gitlab worker
+ services.gitlab-runner = {
+ enable = true;
+ services.docker = {
+ registrationConfigFile = "/run/secrets/gitlab-runner-registration";
+ executor = "docker";
+ tagList = ["docker"];
+ runUntagged = true;
+ description = "Docker runner";
+ };
+ };
+
+ };
+
+}