aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/mrpump.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-10-06 11:13:35 +0200
committerKarel Kočí <cynerd@email.cz>2022-10-06 11:13:56 +0200
commit3116b5d11cfcb37e62de112b710c0e3241585e6f (patch)
tree3ae1bfae79ce5d60ab0ff3ffca85f5d720c57498 /nixos/machine/mrpump.nix
parent507252f378872f2b14751dc800fe5f1606c404b4 (diff)
downloadnixos-personal-3116b5d11cfcb37e62de112b710c0e3241585e6f.tar.gz
nixos-personal-3116b5d11cfcb37e62de112b710c0e3241585e6f.tar.bz2
nixos-personal-3116b5d11cfcb37e62de112b710c0e3241585e6f.zip
nixos/mrpump: add new device
Diffstat (limited to 'nixos/machine/mrpump.nix')
-rw-r--r--nixos/machine/mrpump.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/nixos/machine/mrpump.nix b/nixos/machine/mrpump.nix
new file mode 100644
index 0000000..818652c
--- /dev/null
+++ b/nixos/machine/mrpump.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ config = {
+ boot.isContainer = true;
+ boot.loader.initScript.enable = true;
+
+ # Gitlab worker
+ services.gitlab-runner = {
+ enable = true;
+ services.docker = {
+ registrationConfigFile = "/run/secrets/gitlab-runner-registration";
+ executor = "docker";
+ tagList = ["docker"];
+ runUntagged = true;
+ description = "Docker runner";
+ };
+ };
+
+ };
+
+}