aboutsummaryrefslogtreecommitdiff
path: root/nixos/configurations/lipwig.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/configurations/lipwig.nix')
-rw-r--r--nixos/configurations/lipwig.nix23
1 files changed, 19 insertions, 4 deletions
diff --git a/nixos/configurations/lipwig.nix b/nixos/configurations/lipwig.nix
index 2e5253d..090e8f5 100644
--- a/nixos/configurations/lipwig.nix
+++ b/nixos/configurations/lipwig.nix
@@ -25,9 +25,16 @@
boot.loader.systemd-boot.enable = false;
- fileSystems."/nas" = {
- device = "172.16.128.63:/nas/2682";
- fsType = "nfs";
+ fileSystems = {
+ "/nas" = {
+ device = "172.16.128.63:/nas/2682";
+ fsType = "nfs";
+ };
+ "/nas/nextcloud-sync" = {
+ device = "/nas/sync";
+ fsType = "fuse.bindfs";
+ options = ["map=syncthing/nextcloud:@syncthing/@nextcloud"];
+ };
};
networking = {
@@ -45,6 +52,15 @@
systemd.network.wait-online.enable = false;
systemd.services.networking-setup.wantedBy = ["network-online.target"];
+ environment.systemPackages = with pkgs; [
+ # fileSystems
+ bindfs
+ # Nextcloud
+ exiftool
+ ffmpeg-headless
+ nodejs
+ ];
+
# Web ######################################################################
services.nginx = {
enable = true;
@@ -219,7 +235,6 @@
};
};
};
- environment.systemPackages = with pkgs; [exiftool ffmpeg-headless nodejs];
# Postgresql ###############################################################
services.postgresql = {