aboutsummaryrefslogtreecommitdiff
path: root/nixos/configurations/lipwig.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2024-04-05 09:40:38 +0200
committerKarel Kočí <cynerd@email.cz>2024-04-05 09:40:38 +0200
commit5a367139ad660808366a941de1e42a72c1606ce6 (patch)
tree540818637ee58fa41f55efdd0e6f6322af9e0a7f /nixos/configurations/lipwig.nix
parenta9738a94e009610163e3c49e9686c12051917af7 (diff)
downloadnixos-personal-5a367139ad660808366a941de1e42a72c1606ce6.tar.gz
nixos-personal-5a367139ad660808366a941de1e42a72c1606ce6.tar.bz2
nixos-personal-5a367139ad660808366a941de1e42a72c1606ce6.zip
Multiple improvements
Diffstat (limited to 'nixos/configurations/lipwig.nix')
-rw-r--r--nixos/configurations/lipwig.nix23
1 files changed, 19 insertions, 4 deletions
diff --git a/nixos/configurations/lipwig.nix b/nixos/configurations/lipwig.nix
index 2e5253d..090e8f5 100644
--- a/nixos/configurations/lipwig.nix
+++ b/nixos/configurations/lipwig.nix
@@ -25,9 +25,16 @@
boot.loader.systemd-boot.enable = false;
- fileSystems."/nas" = {
- device = "172.16.128.63:/nas/2682";
- fsType = "nfs";
+ fileSystems = {
+ "/nas" = {
+ device = "172.16.128.63:/nas/2682";
+ fsType = "nfs";
+ };
+ "/nas/nextcloud-sync" = {
+ device = "/nas/sync";
+ fsType = "fuse.bindfs";
+ options = ["map=syncthing/nextcloud:@syncthing/@nextcloud"];
+ };
};
networking = {
@@ -45,6 +52,15 @@
systemd.network.wait-online.enable = false;
systemd.services.networking-setup.wantedBy = ["network-online.target"];
+ environment.systemPackages = with pkgs; [
+ # fileSystems
+ bindfs
+ # Nextcloud
+ exiftool
+ ffmpeg-headless
+ nodejs
+ ];
+
# Web ######################################################################
services.nginx = {
enable = true;
@@ -219,7 +235,6 @@
};
};
};
- environment.systemPackages = with pkgs; [exiftool ffmpeg-headless nodejs];
# Postgresql ###############################################################
services.postgresql = {