aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index d39fbff..3de33af 100644
--- a/flake.nix
+++ b/flake.nix
@@ -25,7 +25,7 @@
modules = hostname: [
self.nixosModules.default
self.nixosModules."machine-${hostname}"
- shellrc.nixosModule
+ shellrc.nixosModules.default
(personal-secret.lib.personalSecrets hostname)
{
networking.hostName = hostname;
@@ -75,6 +75,8 @@
packages = filterPackages system (flattenTree (
import ./pkgs { nixpkgs = nixpkgs.legacyPackages."${system}"; }
));
+ devShells = filterPackages system
+ (import ./develop { inherit nixpkgs; inherit shellrc; inherit system; });
});
}