aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-06-11 22:36:26 +0200
committerKarel Kočí <cynerd@email.cz>2022-06-11 22:36:26 +0200
commitdce47feee03117cb0b9596e2cd30b3d467afddbb (patch)
tree95e48127b3f0b99f9852aff5fc2bd53460839d4e /flake.nix
parentcc80b8780d1ba104e355dbe3697f6679b81cad50 (diff)
downloadnixos-personal-dce47feee03117cb0b9596e2cd30b3d467afddbb.tar.gz
nixos-personal-dce47feee03117cb0b9596e2cd30b3d467afddbb.tar.bz2
nixos-personal-dce47feee03117cb0b9596e2cd30b3d467afddbb.zip
Add development to spawn quickly shells
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index d39fbff..3de33af 100644
--- a/flake.nix
+++ b/flake.nix
@@ -25,7 +25,7 @@
modules = hostname: [
self.nixosModules.default
self.nixosModules."machine-${hostname}"
- shellrc.nixosModule
+ shellrc.nixosModules.default
(personal-secret.lib.personalSecrets hostname)
{
networking.hostName = hostname;
@@ -75,6 +75,8 @@
packages = filterPackages system (flattenTree (
import ./pkgs { nixpkgs = nixpkgs.legacyPackages."${system}"; }
));
+ devShells = filterPackages system
+ (import ./develop { inherit nixpkgs; inherit shellrc; inherit system; });
});
}