aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/generic.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-09-15 10:08:12 +0200
committerKarel Kočí <cynerd@email.cz>2022-09-15 10:08:12 +0200
commit7b5f6bd95230c4eaac16d3fc2f02365497bd63d7 (patch)
tree6815e7a9492211e79a63a6189373d5616268cfbb /nixos/modules/generic.nix
parent929d898bf77ee0d8f8d4f504483369411e2009da (diff)
downloadnixos-personal-7b5f6bd95230c4eaac16d3fc2f02365497bd63d7.tar.gz
nixos-personal-7b5f6bd95230c4eaac16d3fc2f02365497bd63d7.tar.bz2
nixos-personal-7b5f6bd95230c4eaac16d3fc2f02365497bd63d7.zip
Add few packages and allow access to the dhcpcd for wheel
Diffstat (limited to 'nixos/modules/generic.nix')
-rw-r--r--nixos/modules/generic.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/nixos/modules/generic.nix b/nixos/modules/generic.nix
index 6469a9d..04957b1 100644
--- a/nixos/modules/generic.nix
+++ b/nixos/modules/generic.nix
@@ -49,7 +49,7 @@ in {
gnumake
exfat exfatprogs
nix-index
- usbutils
+ usbutils pciutils
# NCurses tools
htop iotop #glances
@@ -112,6 +112,8 @@ in {
security.sudo.extraRules = [
{ groups = [ "wheel" ]; commands = [ "ALL" ]; }
];
+ networking.dhcpcd.extraConfig = "controlgroup wheel";
+ environment.etc."dhcpcd.conf".text = "controlgroup wheel";
services.openssh.enable = true;