aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-11-03 12:28:59 +0100
committerKarel Kočí <cynerd@email.cz>2022-11-03 12:28:59 +0100
commit0be1cd4e5dde86f917f8c76c4bac7599c0124a31 (patch)
tree4e4353088d677aa5b9d1c2439ad79cdce60cab01 /flake.nix
parenta01159cb22acfb754037047e5c060df2b5b2caeb (diff)
downloadnixos-personal-0be1cd4e5dde86f917f8c76c4bac7599c0124a31.tar.gz
nixos-personal-0be1cd4e5dde86f917f8c76c4bac7599c0124a31.tar.bz2
nixos-personal-0be1cd4e5dde86f917f8c76c4bac7599c0124a31.zip
flake: tweak inputs and update
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index adfd959..d768e3b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,8 +2,9 @@
description = "Cynerd's personal flake";
inputs = {
- shellrc.url = "git+https://git.cynerd.cz/shellrc";
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable-small";
personal-secret.url = "git+ssh://git@cynerd.cz/nixos-personal-secret";
+
nixturris = {
url = "github:cynerd/nixturris";
#url = "/home/cynerd/projects/nixturris";
@@ -11,15 +12,16 @@
};
vpsadminos.url = "github:vpsfreecz/vpsadminos";
+ shellrc.url = "git+https://git.cynerd.cz/shellrc";
sterm.url = "github:wentasah/sterm";
usbkey.url = "git+https://git.cynerd.cz/usbkey?ref=modules";
};
outputs = { self
, nixpkgs, flake-utils, nixos-hardware, nix
- , shellrc, usbkey, nixturris, personal-secret
- , vpsadminos
- , sterm
+ , personal-secret
+ , nixturris, vpsadminos
+ , shellrc, usbkey, sterm
}:
with flake-utils.lib;
{