aboutsummaryrefslogtreecommitdiff
path: root/devShells/riscv.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-07-21 10:35:49 +0200
committerKarel Kočí <cynerd@email.cz>2022-07-21 10:35:49 +0200
commite24af8437a690ef09c3145ea9f835197a60dd1ee (patch)
tree363051a7cffd5672ad8fe48e722259ebdeee33a6 /devShells/riscv.nix
parentdd4951d40bf5c7da87b003b2bf1ab05576397bb3 (diff)
downloadnixos-personal-e24af8437a690ef09c3145ea9f835197a60dd1ee.tar.gz
nixos-personal-e24af8437a690ef09c3145ea9f835197a60dd1ee.tar.bz2
nixos-personal-e24af8437a690ef09c3145ea9f835197a60dd1ee.zip
nixShells: provide default shell with my default configuration
Diffstat (limited to 'devShells/riscv.nix')
-rw-r--r--devShells/riscv.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/devShells/riscv.nix b/devShells/riscv.nix
index ded7859..bd19eef 100644
--- a/devShells/riscv.nix
+++ b/devShells/riscv.nix
@@ -1,4 +1,4 @@
-{ nixpkgs, shellrc, system }:
+{ system, nixpkgs, default }:
let
pkgs = nixpkgs.legacyPackages.${system};
pkgs-riscv = import nixpkgs.outPath {
@@ -18,6 +18,6 @@ in pkgs.mkShell {
]) ++ (with pkgs-riscv.buildPackages; [
gcc pkg-config
]);
- inputsFrom = [ shellrc.packages.${system}.default ];
+ inputsFrom = [ default ];
meta.platforms = nixpkgs.lib.platforms.linux;
}