summaryrefslogtreecommitdiff
path: root/net-im/rambox/rambox-0.7.7-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/rambox/rambox-0.7.7-r2.ebuild')
-rw-r--r--net-im/rambox/rambox-0.7.7-r2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/net-im/rambox/rambox-0.7.7-r2.ebuild b/net-im/rambox/rambox-0.7.7-r2.ebuild
new file mode 100644
index 0000000..9f02b32
--- /dev/null
+++ b/net-im/rambox/rambox-0.7.7-r2.ebuild
@@ -0,0 +1,20 @@
+EAPI=7
+
+inherit desktop
+
+DESCRIPTION="Messaging and emailing app that combines common web applications into one"
+HOMEPAGE="https://github.com/ramboxapp/community-edition"
+SRC_URI="https://github.com/ramboxapp/community-edition/releases/download/${PV}/Rambox-${PV}-linux-x64.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="GPL-3.0+"
+SLOT="0"
+KEYWORDS="amd64"
+
+src_install() {
+ dodir /opt
+ cp -R "${S}/Rambox-${PV}-linux-x64/" "${D}/opt/rambox/" || die "Install failed!"
+ dodir /usr/bin
+ ln -s /opt/rambox/rambox "${D}/usr/bin/rambox"
+ make_desktop_entry rambox Rambox
+}