summaryrefslogtreecommitdiff
path: root/dev-util/laminar/laminar-0.6.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/laminar/laminar-0.6.0.4.ebuild')
-rw-r--r--dev-util/laminar/laminar-0.6.0.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/laminar/laminar-0.6.0.4.ebuild b/dev-util/laminar/laminar-0.6.0.4.ebuild
new file mode 100644
index 0000000..bff8169
--- /dev/null
+++ b/dev-util/laminar/laminar-0.6.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+HASHV="cc7d9fa4dabffdbfa5224cc1e667bc96cfa8ee5e"
+DESCRIPTION="Lightweight and modular Continuous Integration service for Linux"
+HOMEPAGE="http://laminar.ohwg.net/"
+SRC_URI="https://github.com/ohwgiles/${PN}/archive/${HASHV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/capnproto
+ dev-libs/rapidjson
+ dev-db/sqlite
+ dev-libs/boost"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/laminar-${HASHV}"
+
+MYCMAKEARGS="-DCMAKE_INSTALL_PREFIX=/"