summaryrefslogtreecommitdiff
path: root/dev-util/laminar/laminar-0.6.0.4.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-02-10 11:42:12 +0100
committerKarel Kočí <cynerd@email.cz>2019-02-10 11:42:12 +0100
commit54c9b2e5ef6b980933ddc5cf68448afd6c1fb1c8 (patch)
tree770554ca9a38ee56e9ff4bb4675789592131c97a /dev-util/laminar/laminar-0.6.0.4.ebuild
parent591a748041123535c0b02683781f8f3b6db95358 (diff)
downloadgentoo-personal-overlay-54c9b2e5ef6b980933ddc5cf68448afd6c1fb1c8.tar.gz
gentoo-personal-overlay-54c9b2e5ef6b980933ddc5cf68448afd6c1fb1c8.tar.bz2
gentoo-personal-overlay-54c9b2e5ef6b980933ddc5cf68448afd6c1fb1c8.zip
Revert "dev-libs/laminar: update to latest upstream commit"
This reverts commit d5567c6534e8926af822f84c734ab2310ab39d35.
Diffstat (limited to 'dev-util/laminar/laminar-0.6.0.4.ebuild')
-rw-r--r--dev-util/laminar/laminar-0.6.0.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/laminar/laminar-0.6.0.4.ebuild b/dev-util/laminar/laminar-0.6.0.4.ebuild
new file mode 100644
index 0000000..bff8169
--- /dev/null
+++ b/dev-util/laminar/laminar-0.6.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+HASHV="cc7d9fa4dabffdbfa5224cc1e667bc96cfa8ee5e"
+DESCRIPTION="Lightweight and modular Continuous Integration service for Linux"
+HOMEPAGE="http://laminar.ohwg.net/"
+SRC_URI="https://github.com/ohwgiles/${PN}/archive/${HASHV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/capnproto
+ dev-libs/rapidjson
+ dev-db/sqlite
+ dev-libs/boost"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/laminar-${HASHV}"
+
+MYCMAKEARGS="-DCMAKE_INSTALL_PREFIX=/"