summaryrefslogtreecommitdiff
path: root/sys-kernel/linux/linux-4.11.9-r1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-07-14 10:56:05 +0200
committerKarel Kočí <cynerd@email.cz>2017-07-14 10:56:05 +0200
commit9001aba7450a11c13c6baa519ac9ae7dcab38575 (patch)
tree29d7f3372a24b3a4934d53df6fa8866d680d4e03 /sys-kernel/linux/linux-4.11.9-r1.ebuild
parent180f71242916b4cd3321de767ee2fc64834b872d (diff)
downloadgentoo-personal-overlay-9001aba7450a11c13c6baa519ac9ae7dcab38575.tar.gz
gentoo-personal-overlay-9001aba7450a11c13c6baa519ac9ae7dcab38575.tar.bz2
gentoo-personal-overlay-9001aba7450a11c13c6baa519ac9ae7dcab38575.zip
Fix linux postinst and postrm
Diffstat (limited to 'sys-kernel/linux/linux-4.11.9-r1.ebuild')
-rw-r--r--sys-kernel/linux/linux-4.11.9-r1.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/sys-kernel/linux/linux-4.11.9-r1.ebuild b/sys-kernel/linux/linux-4.11.9-r1.ebuild
deleted file mode 100644
index 0dcdd3e..0000000
--- a/sys-kernel/linux/linux-4.11.9-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VER="${PV%-r*}"
-REV="r${PV##*-r}"
-
-DESCRIPTION="Linux kernel"
-HOMEPAGE="http://kernel.org/"
-SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/snapshot/linux-stable-${VER}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/linux-stable-${VER}"
-
-LICENSE="GPLv2"
-SLOT="${PV}"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- sys-boot/myinitramfs"
-
-src_configure() {
- # Fix ARCH variable
- [ "$ARCH" = "amd64" ] && ARCH="x86"
-
- "${FILESDIR}"/config_prepare.sh || die "Configuration application failed"
-}
-
-src_install() {
- emake modules_install INSTALL_MOD_PATH="${D}" INSTALL_FW_PATH="${D}/lib/firmware/${PV}"
-
- dodir /boot
- insinto /boot
- newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
-
- # Package source (kind of annoying because of some packages expecting it)
- emake clean
- dodir /usr/src
- cp -a "${S}" "${D}/usr/src/linux-${PV}"
-}
-
-# Link /usr/src/linux to newest kernel
-src_link() {
- (
- cd "${ROOT}/usr/src"
- rm -f linux
- ln -s $(ls | grep "linux-" | sort | tail -1) linux
- )
-}
-
-pkg_postinst() {
- # Add label to syslinux config if there is non yet
- SYSLINUX="${ROOT}/boot/syslinux/syslinux.cfg"
- if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
- ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
- if [ -n "$ARGS" ]; then
- sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS}\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
- sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
- else
- eerror "Adding label to syslinux configuration failed as there are no arguments"
- fi
- fi
- src_link
-}
-
-pkg_prerm() {
- # Remove label from syslinux config
- sed -i "/^LABEL gentoo-${PV}(|-recovery)$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
-}
-
-pkg_postrm() {
- src_link
-}