summaryrefslogtreecommitdiff
path: root/sys-kernel/linux
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-07-14 10:56:05 +0200
committerKarel Kočí <cynerd@email.cz>2017-07-14 10:56:05 +0200
commit9001aba7450a11c13c6baa519ac9ae7dcab38575 (patch)
tree29d7f3372a24b3a4934d53df6fa8866d680d4e03 /sys-kernel/linux
parent180f71242916b4cd3321de767ee2fc64834b872d (diff)
downloadgentoo-personal-overlay-9001aba7450a11c13c6baa519ac9ae7dcab38575.tar.gz
gentoo-personal-overlay-9001aba7450a11c13c6baa519ac9ae7dcab38575.tar.bz2
gentoo-personal-overlay-9001aba7450a11c13c6baa519ac9ae7dcab38575.zip
Fix linux postinst and postrm
Diffstat (limited to 'sys-kernel/linux')
-rw-r--r--sys-kernel/linux/linux-4.11.9-r2.ebuild (renamed from sys-kernel/linux/linux-4.11.9-r1.ebuild)4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-kernel/linux/linux-4.11.9-r1.ebuild b/sys-kernel/linux/linux-4.11.9-r2.ebuild
index 0dcdd3e..47e48ea 100644
--- a/sys-kernel/linux/linux-4.11.9-r1.ebuild
+++ b/sys-kernel/linux/linux-4.11.9-r2.ebuild
@@ -56,7 +56,7 @@ pkg_postinst() {
ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
if [ -n "$ARGS" ]; then
sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS}\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding label to syslinux configuration failed!"
- sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
+ sed -i "/^## Dynamic recovery labels ##$/a LABEL gentoo-${PV}-recovery\n\tMENU LABEL Gentoo ${PV} - Recovery\n\tLINUX ../bzlinux-${PV}\n\tAPPEND ${ARGS} recovery\n\tINITRD ../initramfs-gentoo\n" "${SYSLINUX}" || eerror "Adding recovery label to syslinux configuration failed!"
else
eerror "Adding label to syslinux configuration failed as there are no arguments"
fi
@@ -66,7 +66,7 @@ pkg_postinst() {
pkg_prerm() {
# Remove label from syslinux config
- sed -i "/^LABEL gentoo-${PV}(|-recovery)$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
+ sed -i "/^LABEL gentoo-${PV}\(\|-recovery\)$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
}
pkg_postrm() {