summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-04-29 21:10:05 +0200
committerKarel Kočí <cynerd@email.cz>2017-04-29 21:10:05 +0200
commita732501dc25554a257a8343cc630aa9ec17d5e79 (patch)
treef69e388a55d38e3e18127e5feed5c461093bf1c6 /sys-boot
parente17beb5c2327a1764069d28a424d489022bc29d1 (diff)
downloadgentoo-personal-overlay-a732501dc25554a257a8343cc630aa9ec17d5e79.tar.gz
gentoo-personal-overlay-a732501dc25554a257a8343cc630aa9ec17d5e79.tar.bz2
gentoo-personal-overlay-a732501dc25554a257a8343cc630aa9ec17d5e79.zip
linux package fixes
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/linux/linux-4.10.13.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/sys-boot/linux/linux-4.10.13.ebuild b/sys-boot/linux/linux-4.10.13.ebuild
index a05ff34..19b339a 100644
--- a/sys-boot/linux/linux-4.10.13.ebuild
+++ b/sys-boot/linux/linux-4.10.13.ebuild
@@ -27,30 +27,26 @@ src_configure() {
[ "$ARCH" = "amd64" ] && ARCH="x86"
emake mrproper
- # TODO support cross compile
# Generate default configuration
emake defconfig
+ # Prepare list of arguments
+ ARGS=""
+ for U in $IUSE; do
+ ARGS="$ARGS $(usev $U)"
+ done
+
# Apply configuration
(
- ARGS=""
- for U in $IUSE; do
- ARGS="$ARGS $(usev $U)"
- done
cd "${S}"
"${FILESDIR}"/config_prepare.sh $ARGS
- )
+ ) || fail
# Process changes
- emake olddefconfig
+ emake olddefconfig 2>/dev/null
# Check changes
- EOUT="$("${FILESDIR}"/config_miss.sh $ARGS)"
- if [ $? -ne 0 ]; then
- eerror "Configuration failed:
-$EOUT"
- fail
- fi
+ eerror "$("${FILESDIR}"/config_miss.sh $ARGS)" || fail
}
src_install() {